import Foundation
let pattern = #"(?m)(?|^(\d+):()()|\G^()([-+]?\d+)(?![:\d])[ \t]+(.*)|\G^()()()[ \t]*$\R*)\R?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
6:
1 my 1st log
-2 my 2nd log
7:
-3 my 3rd log
4 my 4th log
-5 my 5th log
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1\t$2\t$3\r\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)