package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([ab]+)|(.+?)`)
var str = `bbccaa`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}