use strict;
my $str = 'bbccaa';
my $regex = qr/([ab]+)|(.+?)/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";