using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*[\\\/]\s+)(?!(?:.*\s|.*\.|\W+)$)(?:[a-zA-Z]:)?(?:(?:[^<>:""\|\?\*\n])+(?:\/\/|\/|\\\\|\\)?)+$";
string input = @"
C://test
C://te?st.html
C:/ test
C://test.html
C://test/hello.html
C:/test/hello.html
//test
/test
//test.html
//10.1.1.107
//10.1.1.107/ test.html
//10.1.1.107/test/hello.html
//10.1.1.107/test/hello
//test/hello.txt.
/test/html
/tes?t/html
/test.html
test.html
//
/
/?/
\\\\
\\
/this/ends/with/a/space
/t!esrtr
C:/hel**o
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}