const regex = /^(?!.*[\\\/]\s+)(?!(?:.*\s|.*\.|\W+)$)(?:[a-zA-Z]:)?(?:(?:[^<>:"\|\?\*\n])+(?:\/\/|\/|\\\\|\\)?)+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*[\\\\\\\/]\\s+)(?!(?:.*\\s|.*\\.|\\W+)$)(?:[a-zA-Z]:)?(?:(?:[^<>:"\\|\\?\\*\\n])+(?:\\\/\\\/|\\\/|\\\\\\\\|\\\\)?)+$', 'gm')
const str = `
C://test
C://te?st.html
C:/ test
C://test.html
C://test/hello.html
C:/test/hello.html
//test
/test
//test.html
//10.1.1.107
//10.1.1.107/ test.html
//10.1.1.107/test/hello.html
//10.1.1.107/test/hello
//test/hello.txt.
/test/html
/tes?t/html
/test.html
test.html
//
/
/?/
\\\\\\\\
\\\\
/this/ends/with/a/space
/t!esrtr
C:/hel**o
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}