re = /^(?!.*[\\\/]\s+)(?!(?:.*\s|.*\.|\W+)$)(?:[a-zA-Z]:)?(?:(?:[^<>:"\|\?\*\n])+(?:\/\/|\/|\\\\|\\)?)+$/m
str = '
C://test
C://te?st.html
C:/ test
C://test.html
C://test/hello.html
C:/test/hello.html
//test
/test
//test.html
//10.1.1.107
//10.1.1.107/ test.html
//10.1.1.107/test/hello.html
//10.1.1.107/test/hello
//test/hello.txt.
/test/html
/tes?t/html
/test.html
test.html
//
/
/?/
\\\\\\\\
\\\\
/this/ends/with/a/space
/t!esrtr
C:/hel**o
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end