const regex = /(\d{4})-((0[1-9])|(1[0-2]))-(0[1-9]|[12][0-9]|3[01])\ (?:[0-1]?[0-9]|[2][1-4]):[0-5]?[0-9]:[0-5]?[0-9]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{4})-((0[1-9])|(1[0-2]))-(0[1-9]|[12][0-9]|3[01])\\ (?:[0-1]?[0-9]|[2][1-4]):[0-5]?[0-9]:[0-5]?[0-9]', 'gm')
const str = `[fw4_allow] []start_time="2018-11-20 16:17:47" end_time="2018-11-20 16:17:47" duration=0 machine_name=Single_FW_M fw_rule_id=5 nat_rule_id=- src_ip=172.16.11.59 userid= src_port=56392 dst_ip=112.107.220.32 dst_port=80 protocol=TCP ingres_if=EXT input interface=eth0 packets_forward=1 packets_backward=0 bytes_forward=64 bytes_backward=0 fragment_info= flag_record=Invalid / FIN1 [AF:-] terminate_reason=TCP Session Install`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}