use strict;
my $str = '[fw4_allow] []start_time="2018-11-20 16:17:47" end_time="2018-11-20 16:17:47" duration=0 machine_name=Single_FW_M fw_rule_id=5 nat_rule_id=- src_ip=172.16.11.59 userid= src_port=56392 dst_ip=112.107.220.32 dst_port=80 protocol=TCP ingres_if=EXT input interface=eth0 packets_forward=1 packets_backward=0 bytes_forward=64 bytes_backward=0 fragment_info= flag_record=Invalid / FIN1 [AF:-] terminate_reason=TCP Session Install';
my $regex = qr/(\d{4})-((0[1-9])|(1[0-2]))-(0[1-9]|[12][0-9]|3[01])\ (?:[0-1]?[0-9]|[2][1-4]):[0-5]?[0-9]:[0-5]?[0-9]/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}