import Foundation
let pattern = #"(\d{4})-((0[1-9])|(1[0-2]))-(0[1-9]|[12][0-9]|3[01])\ (?:[0-1]?[0-9]|[2][1-4]):[0-5]?[0-9]:[0-5]?[0-9]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"[fw4_allow] []start_time="2018-11-20 16:17:47" end_time="2018-11-20 16:17:47" duration=0 machine_name=Single_FW_M fw_rule_id=5 nat_rule_id=- src_ip=172.16.11.59 userid= src_port=56392 dst_ip=112.107.220.32 dst_port=80 protocol=TCP ingres_if=EXT input interface=eth0 packets_forward=1 packets_backward=0 bytes_forward=64 bytes_backward=0 fragment_info= flag_record=Invalid / FIN1 [AF:-] terminate_reason=TCP Session Install"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)