import re
regex = re.compile(r"(?:\G(?!^)|NOTE)\K\s", flags=re.MULTILINE)
test_str = ("NOTE 3/1\n"
"NOTE 4.3%")
subst = "@"
result = regex.sub(subst, test_str)
if result:
print(result)