import Foundation
let pattern = #"(?:\G(?!^)|NOTE)\K\s"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
NOTE 3/1
NOTE 4.3%
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"@"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)