#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\d{4})(?:-(\d{2})(?:-(\d{2}))?)?(?:\s(.+))?" & @CRLF & _
""
Local $sString = "2021 abc" & @CRLF & _
"2021-02 abc" & @CRLF & _
"2021-02-30" & @CRLF & _
"" & @CRLF & _
"2021" & @CRLF & _
"" & @CRLF & _
"2021-02" & @CRLF & _
"" & @CRLF & _
"2021-02-30 abc" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")