// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d{4})(?:-(\d{2})(?:-(\d{2}))?)?(?:\s(.+))?
").unwrap();
let string = "2021 abc
2021-02 abc
2021-02-30
2021
2021-02
2021-02-30 abc
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}