#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:.*\P{L})?\K\p{L}+-\d+"
Local $sString = "BUG-KEYWORD-BUG-101" & @CRLF & _
"ABC-10" & @CRLF & _
"DEF-10327" & @CRLF & _
"Output is referred in ABC-1043" & @CRLF & _
"Please refer DEF-11234" & @CRLF & _
"Please refer DEF-11234 and TRE-5555 here" & @CRLF & _
" ^^^^^^^^^ ^^^"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")