$re = '/^(?:.*\P{L})?\K\p{L}+-\d+/m';
$str = 'BUG-KEYWORD-BUG-101
ABC-10
DEF-10327
Output is referred in ABC-1043
Please refer DEF-11234
Please refer DEF-11234 and TRE-5555 here
^^^^^^^^^ ^^^';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);