import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:.*\\P{L})?\\K\\p{L}+-\\d+";
final String string = "BUG-KEYWORD-BUG-101\n"
+ "ABC-10\n"
+ "DEF-10327\n"
+ "Output is referred in ABC-1043\n"
+ "Please refer DEF-11234\n"
+ "Please refer DEF-11234 and TRE-5555 here\n"
+ " ^^^^^^^^^ ^^^";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}