const regex = /<(?=div)\b[^>]*>[\s\S]*?<(span)\b[^>]*>[\s\S]*?<\/\1>[\s\S]*?(?<=<\/div>)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<(?=div)\\b[^>]*>[\\s\\S]*?<(span)\\b[^>]*>[\\s\\S]*?<\\\/\\1>[\\s\\S]*?(?<=<\\\/div>)', 'gm')
const str = `<div><span class="_1L8oL _2EVlr">?</span> <span><strong>Quantifier</strong> — Matches between <span class="Z3H4l">zero</span> and <span class="Z3H4l">one</span> times, as many times as possible, giving back as needed <span class="_2P7Bb">(greedy)</span>
</div>
<div>
<span></span>
</div>
<div>
<img></img>
<span></span>
</div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}