import re
regex = re.compile(r"<(?=div)\b[^>]*>[\s\S]*?<(span)\b[^>]*>[\s\S]*?<\/\1>[\s\S]*?(?<=<\/div>)", flags=re.MULTILINE)
test_str = ("<div><span class=\"_1L8oL _2EVlr\">?</span> <span><strong>Quantifier</strong> — Matches between <span class=\"Z3H4l\">zero</span> and <span class=\"Z3H4l\">one</span> times, as many times as possible, giving back as needed <span class=\"_2P7Bb\">(greedy)</span>\n"
"</div>\n"
"<div>\n"
"<span></span>\n"
"</div>\n"
"<div>\n"
"<img></img>\n"
"<span></span>\n"
"</div>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")