$re = '/<(?=div)\b[^>]*>[\s\S]*?<(span)\b[^>]*>[\s\S]*?<\/\1>[\s\S]*?(?<=<\/div>)/m';
$str = '<div><span class="_1L8oL _2EVlr">?</span> <span><strong>Quantifier</strong> — Matches between <span class="Z3H4l">zero</span> and <span class="Z3H4l">one</span> times, as many times as possible, giving back as needed <span class="_2P7Bb">(greedy)</span>
</div>
<div>
<span></span>
</div>
<div>
<img></img>
<span></span>
</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);