# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(\w+)\s\1\b//g;t' <<< "Goodbye bye bye world world world
Sam went went to to to his business
Reya is is the the best player in eye eye game"