$re = '/\b(\w+)\s\1\b/';
$str = 'Goodbye bye bye world world world
Sam went went to to to his business
Reya is is the the best player in eye eye game';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;