use strict;
my $str = 'Goodbye bye bye world world world
Sam went went to to to his business
Reya is is the the best player in eye eye game';
my $regex = qr/\b(\w+)\s\1\b/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";