use strict;
my $str = 'wo-wo-wo-wonder -> wonder
hi-hi-hi-hi -> hi
wo-wo-wo -> wo';
my $regex = qr/\b(\w+)(?:-\1)*-(\1)/mp;
my $subst = '\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";