re = /\b(\w+)(?:-\1)*-(\1)/m
str = 'wo-wo-wo-wonder -> wonder
hi-hi-hi-hi -> hi
wo-wo-wo -> wo'
subst = '\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result