#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i:\b(?:m(?:s(?:ysaccessobjects|ysaces|ysobjects|ysqueries|ysrelationships|ysaccessstorage|ysaccessxml|ysmodules|ysmodules2|db)|aster\.\.sysdatabases|ysql\.db)\b|s(?:ys(?:\.database_name|aux)\b|chema(?:\W*\(|_name\b)|qlite(_temp)?_master\b)|d(?:atabas|b_nam)e\W*\(|information_schema\b|pg_(catalog|toast)\b|northwind\b|tempdb\b))"
Local $sString = "msysaccessobjects" & @CRLF & _
"msysaces" & @CRLF & _
"msysobjects" & @CRLF & _
"msysqueries" & @CRLF & _
"msysrelationships" & @CRLF & _
"msysaccessstorage" & @CRLF & _
"msysaccessxml" & @CRLF & _
"msysmodules" & @CRLF & _
"msysmodules2" & @CRLF & _
"msdb" & @CRLF & _
"mysql.db" & @CRLF & _
"master..sysdatabases" & @CRLF & _
"sys.database_name" & @CRLF & _
"sysaux" & @CRLF & _
"schema_name" & @CRLF & _
"sqlite_temp_master" & @CRLF & _
"database(" & @CRLF & _
"db_name(" & @CRLF & _
"information_schema" & @CRLF & _
"pg_catalog" & @CRLF & _
"pg_toast" & @CRLF & _
"northwind" & @CRLF & _
"tempdb" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")