import Foundation
let pattern = #"(?i:\b(?:m(?:s(?:ysaccessobjects|ysaces|ysobjects|ysqueries|ysrelationships|ysaccessstorage|ysaccessxml|ysmodules|ysmodules2|db)|aster\.\.sysdatabases|ysql\.db)\b|s(?:ys(?:\.database_name|aux)\b|chema(?:\W*\(|_name\b)|qlite(_temp)?_master\b)|d(?:atabas|b_nam)e\W*\(|information_schema\b|pg_(catalog|toast)\b|northwind\b|tempdb\b))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
msysaccessobjects
msysaces
msysobjects
msysqueries
msysrelationships
msysaccessstorage
msysaccessxml
msysmodules
msysmodules2
msdb
mysql.db
master..sysdatabases
sys.database_name
sysaux
schema_name
sqlite_temp_master
database(
db_name(
information_schema
pg_catalog
pg_toast
northwind
tempdb
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)