package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i:\b(?:m(?:s(?:ysaccessobjects|ysaces|ysobjects|ysqueries|ysrelationships|ysaccessstorage|ysaccessxml|ysmodules|ysmodules2|db)|aster\.\.sysdatabases|ysql\.db)\b|s(?:ys(?:\.database_name|aux)\b|chema(?:\W*\(|_name\b)|qlite(_temp)?_master\b)|d(?:atabas|b_nam)e\W*\(|information_schema\b|pg_(catalog|toast)\b|northwind\b|tempdb\b))`)
var str = `msysaccessobjects
msysaces
msysobjects
msysqueries
msysrelationships
msysaccessstorage
msysaccessxml
msysmodules
msysmodules2
msdb
mysql.db
master..sysdatabases
sys.database_name
sysaux
schema_name
sqlite_temp_master
database(
db_name(
information_schema
pg_catalog
pg_toast
northwind
tempdb
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}