#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^\040*)(\w*)(\040*)(=)(\040*)(\w*)"
Local $sString = "# '#' character is used for comments - like in Bash" & @CRLF & _
"# '*' character is a wildcart character, ".*" is the regex equivalence" & @CRLF & _
"" & @CRLF & _
"# set x-ambles, the strings to be printed before, in-between and after the group of bitfields" & @CRLF & _
"preamble="#ifdef DEBUG"" & @CRLF & _
"interamble=#else" & @CRLF & _
"postamble=#endif" & @CRLF & _
"" & @CRLF & _
"# set the alignment value" & @CRLF & _
"alignment=16" & @CRLF & _
"" & @CRLF & _
"# bitfield names to be ignored" & @CRLF & _
"ignore=padding*,dummy*,doNotCare* " & @CRLF & _
"" & @CRLF & _
"# indent " & @CRLF & _
"indent=" "" & @CRLF & _
"" & @CRLF & _
"# padding type" & @CRLF & _
" padding = unsigned" & @CRLF & _
"" & @CRLF & _
"# this whould not be searched by C++ engine " & @CRLF & _
"files=*.h,*.c" & @CRLF & _
"" & @CRLF & _
"#prefix of type name to be searched" & @CRLF & _
"prefix=typedef" & @CRLF & _
"" & @CRLF & _
"#do or do not mirror" & @CRLF & _
"mirror=true" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")