// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^\040*)(\w*)(\040*)(=)(\040*)(\w*)").unwrap();
let string = "# '#' character is used for comments - like in Bash
# '*' character is a wildcart character, \".*\" is the regex equivalence
# set x-ambles, the strings to be printed before, in-between and after the group of bitfields
preamble=\"#ifdef DEBUG\"
interamble=#else
postamble=#endif
# set the alignment value
alignment=16
# bitfield names to be ignored
ignore=padding*,dummy*,doNotCare*
# indent
indent=\" \"
# padding type
padding = unsigned
# this whould not be searched by C++ engine
files=*.h,*.c
#prefix of type name to be searched
prefix=typedef
#do or do not mirror
mirror=true
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}