$re = '/(^\040*)(\w*)(\040*)(=)(\040*)(\w*)/m';
$str = '# \'#\' character is used for comments - like in Bash
# \'*\' character is a wildcart character, ".*" is the regex equivalence
# set x-ambles, the strings to be printed before, in-between and after the group of bitfields
preamble="#ifdef DEBUG"
interamble=#else
postamble=#endif
# set the alignment value
alignment=16
# bitfield names to be ignored
ignore=padding*,dummy*,doNotCare*
# indent
indent=" "
# padding type
padding = unsigned
# this whould not be searched by C++ engine
files=*.h,*.c
#prefix of type name to be searched
prefix=typedef
#do or do not mirror
mirror=true
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);