package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\D+|\d*\.?\d+`)
var str = `We have the number 10 and 10.3, and i want to split both`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}