$re = '/\D+|\d*\.?\d+/';
$str = 'We have the number 10 and 10.3, and i want to split both';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);