re = /\D+|\d*\.?\d+/
str = 'We have the number 10 and 10.3, and i want to split both'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end