#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?m)^(?:\d+\.\d+|\d{2,})$"
Local $sString = "1.20" & @CRLF & _
"1" & @CRLF & _
"99%" & @CRLF & _
"6.75" & @CRLF & _
"X" & @CRLF & _
"-" & @CRLF & _
"14" & @CRLF & _
"2" & @CRLF & _
"1%" & @CRLF & _
"+72"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")