$re = '/(?m)^(?:\d+\.\d+|\d{2,})$/m';
$str = '1.20
1
99%
6.75
X
-
14
2
1%
+72';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);