import re
regex = re.compile(r"(?m)^(?:\d+\.\d+|\d{2,})$", flags=re.MULTILINE)
test_str = ("1.20\n"
"1\n"
"99%\n"
"6.75\n"
"X\n"
"-\n"
"14\n"
"2\n"
"1%\n"
"+72")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")