import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*):(\\d+):\\s+(Failure)$";
final String string = "[ RUN ] TestSuite.TestCase1\n"
+ "[ OK ] TestSuite.TestCase1(0 ms)\n"
+ "[ RUN ] TestSuite.TestCase2\n"
+ "C:\\file\\path\\TestFile.cpp:547: Failure\n"
+ "Actual function call count doesn't match EXPECT_CALL(observer, HandleFunction(&argument))...\n"
+ " Expected: to be called once\n"
+ " Actual: never called - unsatisfied and active\n"
+ "[ FAILED ] TestSuite.TestCase2(32 ms)\n"
+ "[ RUN ] TestSuite.TestCase3\n"
+ "[ OK ] TestSuite.TestCase3(0 ms)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}