const regex = /^(.*):(\d+):\s+(Failure)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*):(\\d+):\\s+(Failure)$', 'gm')
const str = `[ RUN ] TestSuite.TestCase1
[ OK ] TestSuite.TestCase1(0 ms)
[ RUN ] TestSuite.TestCase2
C:\\file\\path\\TestFile.cpp:547: Failure
Actual function call count doesn't match EXPECT_CALL(observer, HandleFunction(&argument))...
Expected: to be called once
Actual: never called - unsatisfied and active
[ FAILED ] TestSuite.TestCase2(32 ms)
[ RUN ] TestSuite.TestCase3
[ OK ] TestSuite.TestCase3(0 ms)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}