$re = '/^(.*):(\d+):\s+(Failure)$/m';
$str = '[ RUN ] TestSuite.TestCase1
[ OK ] TestSuite.TestCase1(0 ms)
[ RUN ] TestSuite.TestCase2
C:\\file\\path\\TestFile.cpp:547: Failure
Actual function call count doesn\'t match EXPECT_CALL(observer, HandleFunction(&argument))...
Expected: to be called once
Actual: never called - unsatisfied and active
[ FAILED ] TestSuite.TestCase2(32 ms)
[ RUN ] TestSuite.TestCase3
[ OK ] TestSuite.TestCase3(0 ms)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);