package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b(Ep\.)\b`)
var str = `This Ep. is 01. TestEp.01Test.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}