$re = '/\b(Ep\.)\b/';
$str = 'This Ep. is 01. TestEp.01Test.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);