const regex = /\b(Ep\.)\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(Ep\\.)\\b', 'g')
const str = `This Ep. is 01. TestEp.01Test.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}