$re = '/_([0-9]+)?_/m';
$str = 'foobar_foobar_190412_foobar_foobar.jpg
foobar_20190311_2372_foobar.jpg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);