// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)_([0-9]+)?_").unwrap();
let string = "foobar_foobar_190412_foobar_foobar.jpg
foobar_20190311_2372_foobar.jpg";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}