re = /_([0-9]+)?_/m
str = 'foobar_foobar_190412_foobar_foobar.jpg
foobar_20190311_2372_foobar.jpg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end