use strict;
my $str = '<div class="list-group font-12"><a class="list-group-item break-word view_file_download at-tip" href="https://kazua.net/bbs/download.php?bo_table=price&wr_id=3504&no=0&page=2"><span class="pull-right hidden-xs text-muted"><i class="fa fa-clock-o"></i> 2018.07.25 02:37</span><i class="fa fa-download"></i> tvN 식샤를 합시다 3 비긴즈.E03.180723.1080p-NEXT.mp4.torrent (209.7K) <span class="orangered">+ 16</span></a>';
my $regex = qr@<div\sclass="[^>]*><a\s[^>]*><span[^>]*>[^>]*></i>[^>]*>[^>]*></i>\s(.*?)\s\([^>]*>[^>]*></a>@mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}