import Foundation
let pattern = #"<div\sclass="[^>]*><a\s[^>]*><span[^>]*>[^>]*></i>[^>]*>[^>]*></i>\s(.*?)\s\([^>]*>[^>]*></a>"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"<div class="list-group font-12"><a class="list-group-item break-word view_file_download at-tip" href="https://kazua.net/bbs/download.php?bo_table=price&wr_id=3504&no=0&page=2"><span class="pull-right hidden-xs text-muted"><i class="fa fa-clock-o"></i> 2018.07.25 02:37</span><i class="fa fa-download"></i> tvN 식샤를 합시다 3 비긴즈.E03.180723.1080p-NEXT.mp4.torrent (209.7K) <span class="orangered">+ 16</span></a>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)