# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<div\sclass=\"[^>]*><a\s[^>]*><span[^>]*>[^>]*></i>[^>]*>[^>]*></i>\s(.*?)\s\([^>]*>[^>]*></a>"
test_str = "<div class=\"list-group font-12\"><a class=\"list-group-item break-word view_file_download at-tip\" href=\"https://kazua.net/bbs/download.php?bo_table=price&wr_id=3504&no=0&page=2\"><span class=\"pull-right hidden-xs text-muted\"><i class=\"fa fa-clock-o\"></i> 2018.07.25 02:37</span><i class=\"fa fa-download\"></i> tvN 식샤를 합시다 3 비긴즈.E03.180723.1080p-NEXT.mp4.torrent (209.7K) <span class=\"orangered\">+ 16</span></a>"
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.