package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d+(?:[,.]\d+)*`)
var str = `mixed string123,456,00indeed
mixed string123,456.00indeed
mixed string123,4indeed
mixed string123,40indeed
mixed string 1,0
mixed string 34.
mixed string 21
mixed string 1,00indeed
mixed string 1,00.00indeed`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}