re = /\d+(?:[,.]\d+)*/m
str = 'mixed string123,456,00indeed
mixed string123,456.00indeed
mixed string123,4indeed
mixed string123,40indeed
mixed string 1,0
mixed string 34.
mixed string 21
mixed string 1,00indeed
mixed string 1,00.00indeed'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end